Nvidia 980m doesn't detect hdmi port



  • Alright, just installed Ubuntu 16.04 on my laptop. I already had it on my desktop, I'm switching to Ubuntu primarily so that windows 10 is running minimally. To much crap gets uploaded to microsoft, so I figure I can minimize that by doing everything possible with Ubuntu and only using windows when what I want to do isn't supported in Ubuntu.

    Anyway, in Ubuntu I've disabled the on-board intel graphics card and everything is peachy. Also the hdmi connection to my tv is working. BUTTTT, in windows 10 the hdmi port stops working when I disable the intel card : /... For the most part it's no biggie for browsing and watching youtube... but it'll suck if I try to play a game on the tv.

    So this would be my first issue where something works in Ubuntu but not Windows. I know none of you use any linux builds, but all of you use windows. Some of you have laptops, so I figure one of you might have experienced this issue when trying to play a game with your laptop plugged into your tv/monitor.

    Any help is much appreciated.


  • admins

    Did you make sure to get the right drivers? I don't know if Nvidia publishes their drivers into the open source repo. You may need to install the closed source ones.



  • @teh-g said in Nvidia 980m doesn't detect hdmi port:

    Did you make sure to get the right drivers? I don't know if Nvidia publishes their drivers into the open source repo. You may need to install the closed source ones.

    Like I said, works fine in linux. In windows the hdmi won't work unless I switch to the onboard card. It's been like that since I got it.



  • I haven't used Ubuntu in a while now, but...

    1. good choice and let me know how get on.
    2. NVidia used to provide driver however it is called something along the lines of NVidia 3rd party driver for Linux, but this it not your issue.
    3. Don't switch off the driver in Win 10 mode. No need.
    4. Oracle of knowledge http://askubuntu.com/ & https://ubuntuforums.org/ should have info for the problem on the forum boards. You won't be the first, as they will discuss Windows and Linux issues as a lot of people run dual boot like you.
    5. Lastly if you own a game in steam, you own the game (for me Borderlands PS) it is available for download in Win and Linux platform. http://www.aspyr.com/search?utf8=✓&search_term=&platform[]=Linux&view_option=Grid_View


  • That's two in a row. IT WORKS FINE IN LINUX!!!! Windows has the prob. Originally I thought that the hdmi port was connected to the onboard card and that's why using the 980m would disable the hdmi out. When I recently noticed it worked fine in Ubuntu, I knew it was an issue in windows and not an intended functionality. Couldn't find much on google, so I posted here.



  • Try messing around Device Manager. Disable the onboard card from there or something like that. Or put the laptop in rice and wait until an Asian comes and fix the problem.



  • @Katsuo said in Nvidia 980m doesn't detect hdmi port:

    Try messing around Device Manager. Disable the onboard card from there or something like that. Or put the laptop in rice and wait until an Asian comes and fix the problem.

    Disabling the onboard card is how I found the issue lol



  • @gord0 As I said, don't recommend disabling it in windows & check the forums linked. They will discuss the issue in Windows there too, as many run dual boot systems too.



  • @Trainsmash said in Nvidia 980m doesn't detect hdmi port:

    @gord0 As I said, don't recommend disabling it in windows & check the forums linked. They will discuss the issue in Windows there too, as many run dual boot systems too.

    Ah, I just saw links to ubuntu forums and stopped reading assuming you were giving more linux advice for a windows problem.

    1. Seems to work quite well. Was playing DiRT Showdown at 1080p and settings maxed with over 60fps on the laptop in question (vsync straight up doesn't work for nvidia users using ubuntu until someone finds a workaround or nvidia patches it with a driver). Just started replaying HL2 on my desktop at 1440p with settings maxed and vsync capping it at 60fps, unfortunately there's no such thing as crossfire for ubuntu (or any linux build) at the moment).

    2. They're currently providing official drivers and i'm using 375.something. "Nouveau" drivers are the alternative and they're garbage unless you plan on not watching any videos, not playing games, and not doing gpu intensive work.

    3. I know, I turned it off before I knew the problem because whatever game I was trying to play at the time was using the onboard instead of the descrete card. At that moment the laptop stopped outputting to the tv, so I figured the hdmi out was only hooked up to the onboard...until I installed ubuntu and was outputting to my tv via the hdmi via my 980m. Which lead me to googling and eventually posting here.

    4. I'll try posting there.

    5. Why is this being brought up? Of course you only need one license...well at least with pc/xbox games. Nintendo and Sony would rather you rebuy the games you already own (fortunately the only games I buy for consoles are exclusives). I currently try the linux build before the windows build. If it shits the bed in linux, I try again in windows. If it still shits the bed, I return it.



  • If memory serves me correct AMD no longer provide driver for their cards.
    I contemplate changing back to ubuntu regularly. I like its efficiency at any task. Gaming is the only thing stopping me.



  • @Trainsmash said in Nvidia 980m doesn't detect hdmi port:

    If memory serves me correct AMD no longer provide driver for their cards.
    I contemplate changing back to ubuntu regularly. I like its efficiency at any task. Gaming is the only thing stopping me.

    AMD still provides drivers. The current one for Ubuntu 16.04 x64 and a Fury X is 16.40. That's what I have running on my desktop.



  • @gord0 said in Nvidia 980m doesn't detect hdmi port:

    a Fury X is 16

    Cool. May just load Ubuntu when I test a new mobo then. Use a AMD card for testing boards. Easier than hassling with Win 7 updates. Good to know, thanks.


Log in to reply
 

Looks like your connection to Gaming Exodus was lost, please wait while we try to reconnect.