September 2017 -- Changelog

9/14/2017 (Part two)

Config Changes

  • Updated to NodeBB 1.6.0
    • This broke stuff temporarily due to some change the NodeBB team made. I worked around the problem and am working with them to find the root cause

9/14/2017

Config Changes

  • FINALLY got NodeBB to automatically restart at a failure
    • Who needs an admin anymore?

Please admin my life

3 Likes

katsuo no way, that’s my job

2 Likes

shiftysatchmo said in September 2017 -- Changelog:

katsuo no way, that’s my job

So automate shifty and in doing so katsuo would be automated.

2 Likes

gord0 said in September 2017 -- Changelog:

shiftysatchmo said in September 2017 -- Changelog:

katsuo no way, that’s my job

So automate shifty and in doing so katsuo would be automated.

automatoception??? :open_mouth:

2 Likes

katsuo said in September 2017 -- Changelog:

gord0 said in September 2017 -- Changelog:

shiftysatchmo said in September 2017 -- Changelog:

katsuo no way, that’s my job

So automate shifty and in doing so katsuo would be automated.

automatoception??? :open_mouth:

0_1505412904029_6297437.jpg

1 Like

I broke stuff, then worked around it, and will probably break it again Soon™.

1 Like

teh_g said in September 2017 -- Changelog:

I broke stuff, then worked around it, and will probably break it again Soon™.

Perhaps you could run a test server locally and try the changes there first? ;]

gord0 said in September 2017 -- Changelog:

teh_g said in September 2017 -- Changelog:

I broke stuff, then worked around it, and will probably break it again Soon™.

Perhaps you could run a test server locally and try the changes there first? ;]

It is interesting, this is actually due to me having the x-content-type-options nosniff header enabled. Apparently there was a change in the MIME types for some template files in 1.6.0. Having that header enabled is making most browsers reject the files (which is technically the proper behavior).

Ultimately it is a defect in NodeBB, but I have a workaround for now. Unfortunately the change requires me to disable CloudFlare and is taking a bit to propagate out.

If I wasn’t so lazy I’d have a dev server too :smiley:

teh_g said in September 2017 -- Changelog:

gord0 said in September 2017 -- Changelog:

teh_g said in September 2017 -- Changelog:

I broke stuff, then worked around it, and will probably break it again Soon™.

Perhaps you could run a test server locally and try the changes there first? ;]

It is interesting, this is actually due to me having the x-content-type-options nosniff header enabled. Apparently there was a change in the MIME types for some template files in 1.6.0. Having that header enabled is making most browsers reject the files (which is technically the proper behavior).

Ultimately it is a defect in NodeBB, but I have a workaround for now. Unfortunately the change requires me to disable CloudFlare and is taking a bit to propagate out.

If I wasn’t so lazy I’d have a dev server too :smiley:

Is NodeBB something anyone can install for free? Like, are you just paying for hosting or paying for the software itself too?

gord0 Just the hosting. NodeBB is free. I’d spin up a VM, but I am so lazy. SO SO SO LAZY

teh_g said in September 2017 -- Changelog:

gord0 Just the hosting. NodeBB is free. I’d spin up a VM, but I am so lazy. SO SO SO LAZY

I was just thinking I could throw up an install on my webserver for testing stuff. Might look into it on the weekend.

Look at ya’ll. Sounding like real nerds.

4 Likes

katsuo said in September 2017 -- Changelog:

Look at ya’ll. Sounding like real nerds.

Pretty much.

Ultimately I don’t think this is a big issue. Browsers are smart enough to sniff the MIME content and set it properly. I will fix it again some day.