Latest AMD drivers


#121

gord0 Also fixes the afterburner bug that was causing it to 0 memory and 0 core clocks.


#122

Another new one! Fixes/enhancements for F1 2017, PUBG, and Destiny 2 beta. Plus a few other random things. See release notes ^


#123

Back to school drivers!..well no not really. Fixes for Moonlight Blade and Titanfall 2 as well as a bunch of random things. See release notes ^


#124

gord0 said in Latest AMD drivers:

Back to school drivers!..well no not really. Fixes for Moonlight Blade and Titanfall 2 as well as a bunch of random things. See release notes ^

Random that Titanfall 2 is getting a patch now.


#125

teh_g said in Latest AMD drivers:

gord0 said in Latest AMD drivers:

Back to school drivers!..well no not really. Fixes for Moonlight Blade and Titanfall 2 as well as a bunch of random things. See release notes ^

Random that Titanfall 2 is getting a patch now.

I think it’s just for older hardware: “Titanfall™ 2 may experience a hang or crash on some Radeon GCN1.0 series graphics products.” . They may have only narrowed it down to a driver thing recently.


#126

gord0 Wow, that is old. Good on AMD for still caring about stuff that is 2+ years old now.


#127

teh_g said in Latest AMD drivers:

gord0 Wow, that is old. Good on AMD for still caring about stuff that is 2+ years old now.

It’s more likely because: EA money


#128

That and maybe xbone and ps4 are gcn1.0 which led them to the issue and fixed it on all platforms.


#129

gord0 I got new drivers and Titanfall 2 wont run at all even after completely fresh install 2 times XD


#130

walruswitalys said in Latest AMD drivers:

gord0 I got new drivers and Titanfall 2 wont run at all even after completely fresh install 2 times XD

What video card?


#131

gord0 XFX r7 370 4GB


#132

walruswitalys said in Latest AMD drivers:

gord0 XFX r7 370 4GB

That’s not a gcn1.0 card. So the issue they fixed was not the issue you’re having. gcn1.0 are the HD7xxx series and some of the R9/R7/R5 2xx cards.


#133

gord0 That sucks i was looking forward to play the campaign but i guess i’ll do it some other time


#134

walruswitalys just roll back


#135

shiftysatchmo It won’t start even on the old ones I was googling and applied some fixes but nothing works


#136

walruswitalys did you clean install the drivers?


#137

shiftysatchmo Yes XD


#138

walruswitalys haha just checking.


#139

shiftysatchmo Feel so depressed :confused: But Arma just got a new campaign out so will play that XD


#140

Must be cursed hardware. I don’t remember any issues with that game. In fact I had the opposite experience you did, it ran perfect at ultra at 1440p60. https://gamingexodus.com/topic/2254/battlefield-1-and-titanfall-2/9